Basic Admin Essentials 2.0 Not Working

Hi, I used this video by Cookie ( ) to create a Basic Admin Essentials 2.0 modification that suits my game. I didn’t change anything except for manual user config, group config, command config and the message things (Kick reason ban reason etc.).

The game is in my group, but it’s private. When I save the script and try to run it in studio, there is just no sign of BAE2.0. No GUI, no commands working, NOTHING.

My script is in ServerScriptService, and its the model from @thefurryfish (Not the module, just the plain old Basic Admin Essentials 2.0 package.)

My script is in:
(sharing in Github Gist since the forum doesn’t allow me to upload files.)

Help is needed, please!

daft question, but dosent bae come in a model
if so, you might need to ungroup it in server storage
if not then oh

:wave: Hey there, welcome to Cookie Tech!

I see that you have a problem regarding BAE 2.0, so let me point you in the right direction!

- Have you published the game to ROBLOX?

When you start off with your game on ROBLOX Studio it isn’t created by you. It is created by an account called ‘Template’. Therefore, it won’t recognise you as the owner.

- Is it in workspace?

Honestly, I recommend keeping it in its original folder within workspace as it moves is automatically for you - have your tried that?

If nothing above helped, it could be a script you have in the plugins? Do you mind showing us the code in every script by using the preformatted text feature?

However, if this fid help please mark this post as ‘Solution’.

Yes, I did publish it. It’s in ServerScriptService in its original model right now, let me try that.

Alrighty, be sure to keep me updated.

Nope, it did not work. I placed the model in Workspace, it didnt work. I ungrouped it in workspace, it didnt work.

Do you mind taking copy an pasting your code into a message so we can look at it?

Try it without ungrouping it.

I already added my code into the original file, Its a Github Gist. I also already tried it without ungrouping as i said.

1 Like

I’ll take a further look now.

I can’t see anything that’s up with the script, so can you join the game and chat ‘/console’ then take a screen shot and send it.


Okay, now say ‘/console’ in the chat then taken and screen shot again.

My console never works really, so I cant do that.

(P.S. i am used to vsc not roblox studio i dont know how to use console please teach me)

10:20:33.540 /screenshot:1: Expected identifier when parsing expression, got ‘/’ - Studio

output gives me this

All you need to do is say ‘/console’ in the chat then a box will appear, then take a screenshot.

10:20:33.540 /screenshot:1: Expected identifier when parsing expression, got ‘/’ - Studio

it gives this error

no box appears

Alright, I’ll take a look at it.

Alright, try pressing F9 instead.

F9 opens the devconsole