Bizarre thing, roblox place stopped opening and parts were arbitrarily scrambled up or down a few studs

Hello. For a while I was having an issue where every time I tried opening a place with Roblox Studio, it “loaded” infinitely, and would not open. I restarted my computer, tried different mediums, reinstalled studio, waited almost a month, and had a studio update or whatever, I remember. Shortly before this started happening, I had changed the graphics in the studio settings. Today, I reset my studio settings, and I was able to open the place I’ve been trying to open. However, after opening it, I saw that the parts (there are thousands) were scrambled on the Y axis. Say, 1/4 of parts were, seemingly arbitrarily, moved up or down like 1-5 studs. Then I closed studio. After trying to reopen the place, the same thing from before happened, where studio “loads” infinitely but the place doesn’t open. Do you know anything about this? I’ll put time to trying to solve this, but if you know anything that could be of help, I would appreciate it.

Never seen or heard of this happening.