Blender not accepting .mtl files?

Hey everyone!

Recently, I was planning to create a new profile picture by creating a new GFX render of my avatar.

However, while applying my textures in Blender, I noticed an issue that’s critical to proper avatar texturing.

Whenever I attempt to upload my texture, I’m prompted to select .png files only. But, as I use to do before, I used the .mtl file, which is the main texture file for most .obj exports.

In shorter words, I’m unable to import my .mtl files into Blender, which is essential if you want your textures showing up properly.

I’ve tried exporting my avatar rigs in Roblox Studio with both R15 and R6 rigs, but neither made a difference.

I recently upgraded to the newest Blender version, which is v3.1, and before that I used v3.0.

Is this an issue with the latest Blender version, or is there a specific setting I need to configure in order for Blender to accept .mtl files again?

Try going to like 2.9 or 3.0.

I would never reccommend backtracking, can we see what happens when you try to import with a screenshot or something?

I use blender 2.79, and I highly recommend it, it’s the best version for GFX in my opinion.

I use blender 2.79, but only for modelling. I have the newest blender on my laptop for GFX.

Ah, blender 2.79 is easiest for me, I’ve had customers request it be made in w.80 which seems impossible for me, haha.

I use blender 3.1, I think it’s the best for GFX, outdated software will just give you worse results

1 Like

Yes, I am noticing the quality of my GFX declining compared to others with gloss parts and stuff tha I can’t do in 2.79, I just find it the easier.

1 Like