Roblox crashing on launch - appears for a split sec, then closes

Hey there! It seems like I’m running into issues every time I try to open Roblox. When I click the ‘PLAY’ button on the game, it opens for a split second, but then closes.

I’ve attempted accessing it through the web version, the Microsoft Store version, and even running it with admin privileges, but unfortunately, none of these methods seem to resolve the crashing problem.

If anyone can help, it would be appreciated as I cannot access Roblox right now.

This is for any game. Just started happening today.

Try on a different account or mobile?

Tried on a different account, still didnt work. Mobile worked, but I’d like to use my PC, as it’s faster.

Have you restarted your computer?

Yes, multiple times.

  • Have you got any strange peripherals plugged in?
  • Have you deleted the roblox cache?

Regarding your first question, I do not have any strange peripherals plugged in.

For your second question, I just cleared my cache for my whole browser and logged back in. However, when I tried joining a game, I encountered the same error.

What about your actual roblox local cache.

I have already tried deleting the Roblox local drive and reinstalling it, if that is what you are mentioning.

See if you can get a log from C:\Users\USERNAME\AppData\Local\Roblox\logs
make sure it ended with _PLAYER or something along the lines of that.

Would this be helpful?

You can try that log.

Nothing looked related to the problem, no errors

Do you have any other idea why this is happening?

Try to go into this folder and try to find Roblox

Then go into the Versions Folder and search for the 2th newest version and open its folder. Now run RobloxPlayerInstaller.exe. It will download roblox again and should work fine.
NOTE: If there is no RobloxPlayerInstaller.exe in the folder or it doesnt work, run the 3th version and repeat this until it works.

I hope this helped you and is what you are searching for!

@RobloxLover123 This wasn’t helpful. Thank you for attempting to assist!

Any help is appreciated!!

Hey @justofficial! Sorry to hear this is happening to you …

I have a few suggestions regarding this issue, as it’s definitely happened to me before. See if any of these are helpful!

  • Clear out all Roblox cache
  • Try to completely re-install the Roblox app, or player
  • See if removing extensions / shaders helps if using the Roblox player
  • Make sure Roblox is up to date
  • Make sure that Roblox is still supported on your device
  • Ensure there are no conflicting programs (anticheats, or other apps)

Some of these should work, but let me know!

1 Like

@RealOH20 I’ve tried all of these. Thank you, I am working with Roblox support to see if they have a solution.