Scripting teleport to part help

I tried to make use command to teleport (To part) but I can tried my best. But it doesn’t try to work. Also I can’t figured out how to change command text.

local groupid = 14656894
local midrank = 9

		if chat == "Team1" then -- teleport part name
			p.Character.HumanoidRootPart.CFrame = -- teleports player

What’s the error you get in output when you try to run the command?

I scripted and I tried but everyone can use this command. Only group rank can do is good but i dont know how to. also I don’t know how to make custom command. I only know talk to teleport.

We need the error from output, it’s all well and good if you’ve got an example, but you won’t get anywhere if we can’t see the errors found inside of the output.

Is that everything error you can see - have you given a go at running the command?

Yea. Let me find error. I will tell you tomorrow.

This should be p.Character.HumanoidRootPart.CFrame = workspace.teleport.CFrame. The CFrame is already on a part & you can’t make a CFrame out of a position.

If this works remember to click the solution button on this message.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.